Echo Problem

Forum to share information about Phone Amego and get help to answer your questions

Re: Echo Problem

Postby psichel_adm » Tue Jul 23, 2013 7:22 pm

Hi Tobias,

This should be fixed in 1.4.15.1 which I posted this afternoon.

Here's what's going on. The API Phone Amego was using for Bluetooth audio is going away in 10.9 (Mavericks) so I've been testing the new API (IOBluetoothHandsFreeDevice). You can actually select between the two API's explicitly by removing your device in Phone Amego and then adding it back as type "Bluetooth -> Alternate HFP".

The new API requires 10.7 or later so there is the possibility to test it with the current installed base to shake out as many issues as possible and report them to Apple while they are actively working on Mavericks. With 1.4.15.1, I restored the old API as the default. The good news is this should work much better in Mavericks possibly including echo cancellation.

For those of you actively using the Bluetooth Speakerphone feature, here are some suggestions:
(1) Chose your preferred audio input explicitly under the More tab.
(2) Adjust the audio input level in Sound Preferences if needed.
(3) You can turn off "Echo Suppression" under the More tab.
(4) To minimize echo and generally improve call audio, avoid using the built-in microphone. Using headphones or an external mic makes big difference.

Enjoy!

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm

Re: Echo Problem

Postby tobias » Thu Jul 25, 2013 1:30 pm

Dear Peter

Many thanks for the quick response, installed and seems to be working as expected. I shall monitor and report any issues.

Best regards
Tobias
tobias
 
Posts: 5
Joined: Tue Jul 23, 2013 1:10 pm

Previous

Return to Phone Amego

Who is online

Users browsing this forum: No registered users and 1 guest