Page 1 of 1

Caller ID is Wrong

PostPosted: Thu Jul 05, 2012 12:08 pm
by KingsleyHill
Hello,

I use Phone Amego with a SNOM 821 phone connected to an Asterisk server. When a call comes in to the phone it properly displays the caller ID of the originating phone (my cell phone for example).

The incoming call window appears on my Mac indicating an incoming call and speaks to me. BUT the incoming call and spoken number is NOT my cell phone number or a name associated with that number. IT IS the sip address of the identity to which the call is directed on the phone. So..it says something like 3439@sip.myserver.com.

Am I doing something wrong? Is there a configuration I am missing? Is the SNOM sending something wrong?

Thanks.

Re: Caller ID is Wrong

PostPosted: Fri Jul 06, 2012 12:30 pm
by psichel_adm
Phone Amego is reporting what the SNOM sent. My SNOM doesn't do this, but I'm not sure what configuration is involved.

Kind Regards,

- Peter

Re: Caller ID is Wrong

PostPosted: Fri Jul 06, 2012 3:30 pm
by KingsleyHill
Thanks Peter for the reply. The data is coming from the phone with the Amego-supplied 'get' code. Are you using an SNOM 821? What version of the software? Is it possible that the get code provided by Amego is incorrect?

Re: Caller ID is Wrong

PostPosted: Tue Jul 10, 2012 4:41 pm
by psichel_adm
I tested with an Snom 300 with the latest firmware (version 8). The phone is issuing an HTTP get request to Phone Amego based on the URL you configured for an incoming call:

http://yourIP:8080/incomingcall/snom?de ... lay_remote

$remote is the remote phone number, and $display_remote is the remote name or caller ID name. If this isn't showing the expected name, perhaps there's a different Snom variable for your phone, or your provider is sending something unexpected.

Kind Regards,

- Peter

Re: Caller ID is Wrong

PostPosted: Thu Jul 12, 2012 4:07 pm
by psichel_adm
I may have a fix in the works. Please Email me directly.

- Peter

Re: Caller ID is Wrong

PostPosted: Tue Jan 06, 2015 8:20 am
by hibaaryan
I have copied the plist file for "External modem" and for "U.S. Robotics" from the package's Devices folder to the Library's Devices folder. But Phone Amego is still dialing with tones rather than pulses. If these plist files need to be modified with Apple's Property List editor, then perhaps I'm not enough of a "power user" to carry that out. I was hoping to enable pulse dialing more by feature selection rather than coding.

Re: Caller ID is Wrong

PostPosted: Sun Jan 11, 2015 5:18 pm
by psichel_adm
The modification is rather trivial. I think you'll want to replace ATD or ATDT with ATDP (P for pulse) in the device configuration file. Phone Amego has a Debug Log you can enable under the More tab to you can see what the program is doing.

Pulse dialing is rarely used anymore. Each low value feature displayed to the user (of which there are many) strips a little joy from the User's experience. Dialectic for example has 100s of user configurable options but finding the one you want and what they all mean is not a pleasant task. The trade-off is to do something very rarely needed, you have to learn a little more about how that feature works.

Kind Regards,

- Peter