Page 1 of 1

Asks for password every time

PostPosted: Mon Oct 29, 2012 1:24 pm
by alvarorb
I'm using Phone Amego 1.4c9 on Mountain Lion and a Polycom phone.
Ever since I rebooted my computer a couple of days ago. I can't use Phone Amego.
Every time I try to dial a number it asks for a user/password. I enter Polycom, 456. Default user/password for my phone and it acts like everything is fine. But it does not dial. If I try dialing again, I'm asked for the user/password again.

Any ideas?

Regards

Alvaro

Re: Asks for password every time

PostPosted: Tue Oct 30, 2012 12:43 pm
by psichel_adm
First, make sure your phone and computer didn't get a new IP address. To check this, review the PA User Guide page for setting up a Polycom phone.

Next, the password should be stored in your Keychain based on the URL which includes the IP address of your phone. Try quitting Phone Amego and starting over, or examining your Keychain if needed.

Kind Regards,

- Peter

Re: Asks for password every time

PostPosted: Thu Jan 02, 2014 7:20 am
by harvey
I am having a similar problem. I am testing the software which looks great but I have some issues getting started

I am using OSX Mavericks
I have the phone IP address as 192.168.1.75
iMac as 192.168.1.78
IP Phone - Polycom 321

The phone is showing in telephone devices - I can delete it and re add it with no problem
When I dial from address book or any other method I get a password request for which i enter "Polycom" and "456"
This appears a few times and then disappears.
The HUD shows a call duration time and says connecting, but the phone has not dialled.When I hang up the phone the. The HUD shows as idle and closes.

Any suggestions as this looks like just the software I need.

Re: Asks for password every time

PostPosted: Sun Jan 05, 2014 1:27 pm
by harvey
Any suggestions - or I will have to give up.....
Please

Re: Asks for password every time

PostPosted: Sat Jan 11, 2014 5:03 pm
by psichel_adm
Hi Alvaro,

Just getting to your message. Phone Amego has a Debug Log you can enable under the More tab to see the data exchange with your phone. My guess is that you might not have the correct administrator password to control your phone.

The reason Phone Amego prompts you for a password to access your phone is because the password it had previously stored in the keychain (if any) was not accepted by your phone. You should be able to see this data exchange in the Phone Amego Debug Log mentioned above.

Kind Regards,

- Peter

Re: Asks for password every time

PostPosted: Sun Jan 12, 2014 10:23 am
by harvey
Peter

thanks for getting back to me - the debug log says

VoipControllerPolycom load failed: possible authentication failure
[Device probe: IP phone]
[Start controller for VoIP Device: IP phone]
VoipControllerPolycom load failed: possible authentication failure
[Device probe: IP phone]
VoipControllerPolycom load failed: possible authentication failure
[Device probe: IP phone]
VoipControllerPolycom load failed: possible authentication failure

In the key chain the PUSH, POLL and VOIP 0 are all set as Polycom and 456

Re: Asks for password every time

PostPosted: Sun Jan 12, 2014 3:44 pm
by psichel_adm
There seems to be a disconnect somewhere. When Phone Amego attempts to load the page with the password it has, the load page request fails:

VoipControllerPolycom load failed: possible authentication failure

Try quitting and restarting the app to make sure it loads the latest password from the Keychain.

- Peter

Re: Asks for password every time

PostPosted: Wed Jan 15, 2014 1:59 pm
by harvey
Quit, restarted -I opened preferences and double clicked the phone and the name and password have loaded.
Still no joy ?

Re: Asks for password every time

PostPosted: Wed Jan 22, 2014 10:37 am
by psichel_adm
Phone Amego stores passwords in your Keychain.

Use Keychain Access to find the Polycom passwords and remove them.
Then launch Phone Amego and re-enter the correct passwords when requested.

Kind Regards,

- Peter