Page 1 of 1

Degrading voice quality on BT

PostPosted: Tue Aug 27, 2013 1:29 pm
by tobias
While the recent BT echo issues have disappeared almost, I have an issue of degrading voice quality using BT. I connect my MB Pro (late 2011, OSX 10.8.4) to an iPhone 5 and a Samsung B5722. Phone calls work alright (although not exactly crystal clear) for the first few minutes, but then voice quality degrades down to a staccato connection to the extent that I have to switch away from BT and pick up the respective handset. It would be great if this could be solved and I am happy to help test.

Tobias

Re: Degrading voice quality on BT

PostPosted: Tue Aug 27, 2013 5:16 pm
by psichel_adm
These are Apple Bluetooth audio issues. You might try the standard Bluetooth troubleshooting tips since not everyone experiences these problems. OS X Mavericks should also help.

Kind Regards,

- Peter

Re: Degrading voice quality on BT

PostPosted: Tue Sep 17, 2013 12:15 pm
by tobias
Hi Peter
I have continuing problems with BT and cannot use Phone Amego since 1.4.17. I hear what you say about Apple, however, my two phones (iPhone 5, Samsung B5722) and mouse connect to BT just fine, however, PA hangs. I used the BT Diagnostics and Explorer, but it seems everything works fine at the Apple end. My two phones used to appear in the connectivity window and have disappeared. When I try to add the iPhone back in, it does not appear in the list. Trying to add the second phone though the same process makes the application hang altogether. Deleting the plist does not solve the problem either. I am a bit stumped here, do you have any suggestions? I attach two screenshots to illustrate.
Tobias
MBPro 2.5GHz i7 16GB, OS X 10.8.5

Screen Shot 2013-09-17 at 16.50.04.PNG
Screen Shot 2013-09-17 at 16.50.04.PNG (133.03 KiB) Viewed 4397 times

Screen Shot 2013-09-17 at 16.51.12.PNG
Screen Shot 2013-09-17 at 16.51.12.PNG (134.82 KiB) Viewed 4397 times

Re: Degrading voice quality on BT

PostPosted: Wed Sep 18, 2013 12:15 am
by psichel_adm
I can see there was a software exception that prevented the Telephone Devices table from loading. I sent you a new version by Email to hopefully correct that so we can troubleshoot from the same code. - Peter

Re: Degrading voice quality on BT

PostPosted: Sat Sep 21, 2013 12:17 pm
by tobias
Hi Peter
Thank you for sending the software update. This did at least allow connectivity to be re-established. However, as I noted in my email to you my Samsung B5722 then went into a repeating 60 sec connection cycles with 10 sec breaks. The new version 1.4.18 didn't correct that. Please see also the attached screenshot with the phone icon in the list having a grey bar in it that seems to suggest an imperfect connection. Are there any tests that I can run or log files that I can send you to assist with fixing this?
Tobias

Screen Shot 2013-09-21 at 17.08.43.png
Screen Shot 2013-09-21 at 17.08.43.png (124 KiB) Viewed 4373 times

Re: Degrading voice quality on BT

PostPosted: Sat Sep 21, 2013 1:39 pm
by psichel_adm
Phone Amego has a Debug Log you can enable under the More tab which should provide more detail on what is happening.

This kind of troubleshooting is usually quicker via direct Email.

Kind Regards,

- Peter

Re: Degrading voice quality on BT

PostPosted: Sun Sep 22, 2013 4:56 pm
by psichel_adm
Problem resolved. We were able to work around a bug in the Samsung B5722.