Page 1 of 1

USB & Mac microphone level issue after Mavericks

PostPosted: Tue Nov 12, 2013 6:00 am
by prmdb
Has anyone else had the following problem: I use Phone Amego with an iOS 7.03 iPhone via Bluetooth and a Sennheiser USB headset connected to my Mac. Upgraded to Mac OSX 1.9 and Phone Amego 1.4.19 (now 1.4.22) and everything seems to work fine except that sound level on the microphone is now very low indeed - so much so that the headset is effectively useless, while hands free through the Mac microphone is just possible but I need to shout to make myself heard.

I've used the OSX Audio Midi Setup to check the levels and both microphones are set at 100%. Skype works perfectly (although I prefer Phone Amego so I can use my contract minutes) with either microphone which makes me think the microphones are OK.

Any ideas?

Thanks

Re: USB & Mac microphone level issue after Mavericks

PostPosted: Fri Nov 15, 2013 10:31 am
by psichel_adm
Does adjusting the Mic input level in Sound Preferences help?

I've heard a few similar comments which means the audio play-through level the Mic to the Bluetooth Audio driver may be at issue.

- Peter

Re: USB & Mac microphone level issue after Mavericks

PostPosted: Fri Nov 15, 2013 1:40 pm
by prmdb
Microphone input level is at 100% - changing it makes things even quieter!

Anything else I can look at?

Re: USB & Mac microphone level issue after Mavericks

PostPosted: Mon Nov 18, 2013 8:14 pm
by psichel_adm
Thanks for the detailed report. I'm investigating. - Peter

Update: It seems to be related to the built-in echo cancellation. I'm looking for a possible work around or way to adjust this.

Re: USB & Mac microphone level issue after Mavericks

PostPosted: Wed Apr 23, 2014 8:20 am
by mnott
Any updates on this? When I use my attached usb microphone, the input level gets switched down the moment the call is connected; I can see that if I e.g. tap on my microphone and have the audio control panel open - moving the sound level slider around there does not help; it is as if the microphone was just muted. I switched off echo (both in plist as well as using 1.4.15.1) and also tried all kinds of other versions of phone amego from your download. I also reset the bluetooth stack and removed all superfluous devices.

Re: USB & Mac microphone level issue after Mavericks

PostPosted: Sun Apr 27, 2014 9:25 pm
by psichel_adm
Unfortunately, there is no way to switch off echo cancellation or control the audio level on Mavericks outside of the audio preferences panel. Apple controls the entire Bluetooth audio stack from Bluetooth driver to speaker and microphone. Please file a bug report with Apple.

I can do likewise and relay to my contact at Apple, but getting bug reports from customers is likely to have more influence.

Kind Regards,

- Peter