Caller ID not displayed

Forum to share information about Phone Amego and get help to answer your questions

Caller ID not displayed

Postby Freek » Wed Nov 13, 2013 5:10 am

Hi,

The Voip provider I use, voipplanet, displays the caller id not in the international format (+ country code etc.) but 00 and if its local they strip the international part.
This results that the number won't be displayed correctly by Phone Amego, since all entries in my phone book on the mac are all in + country code etc.

To me it could be simply fixed since I noticed that Phone Amgego will search the number starting with the last digit first, which is perfect.
Would it be possible to specify in Phone Amego the maximum digits to match?
If you specify for example 8 or 9, the chances that there are identical numbers are minimum.

Freek
Freek
 
Posts: 8
Joined: Thu Nov 07, 2013 2:57 am

Re: Caller ID not displayed

Postby psichel_adm » Fri Nov 15, 2013 10:42 am

Phone Amego first looks to match the last 4 digits of the phone number. It then looks to see if one phone number string is a suffix of the other. The prefix in your Address Book shouldn't matter as long as caller ID received is a suffix of the entry in your Address Book. Is there some reason this wouldn't be the case?

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm

Re: Caller ID not displayed

Postby Freek » Fri Nov 15, 2013 12:15 pm

I used in the preference window of Phone Amego the find function and it uses as much numbers to match as you type in.
And i have the idea that the software is doing the same when a phone number is passed on from a device to phone amego app.

SInce i have all international notations in my address book and however the voip provider does not pass them on like that;
For example in phone book +31 6 1234 5678
the voip provider gives me 0031 6 1234 5678 no match
or if its a local number the voip provider gives me 06 1234 5678 no match
Freek
 
Posts: 8
Joined: Thu Nov 07, 2013 2:57 am

Re: Caller ID not displayed

Postby psichel_adm » Mon Nov 18, 2013 6:16 pm

Wow, what a mess.

For example in phone book +31 6 1234 5678
the voip provider gives me 0031 6 1234 5678 no match
or if its a local number the voip provider gives me 06 1234 5678 no match


Under the Dialing options tab, if you set the National Dialing Prefix to "0", Phone Amego should strip this from the incoming number before comparing it to the number in your Address Book. I'll need to update Phone Amego to also strip "00" in this case.

I'd like to send you a new version for testing.

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm


Return to Phone Amego

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

cron