Activating Scripts in outlook

Forum to share information about Phone Amego and get help to answer your questions

Activating Scripts in outlook

Postby u352 » Thu Apr 17, 2014 1:12 pm

Ive downloaded the some scripts from the extras section and have placed them library/application support folder.What do i do from here?

T
u352
 
Posts: 2
Joined: Thu Apr 17, 2014 11:58 am

Re: Activating Scripts in outlook

Postby psichel_adm » Thu Apr 17, 2014 9:23 pm

See http://www.sustworks.com/pa_guide/scripting.html

Can you say more about what you want to do and which step isn't clear?

For dialing, you can select a phone number in Outlook and press Control-Shift-2 or use PopClip to click directly.

For inbound Caller ID, you want to set a script for the "call_from()", "call_info()", or "did_dial()" event.

Were you able to find the MS Outlook scripts in the Phone Amego Extra's folder?

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm

Re: Activating Scripts in outlook

Postby u352 » Fri Apr 18, 2014 8:16 am

Ok so let me try again.

Ive downloaded the Phone Amegos Extras and dropped them in the OUTLOOKS Script folder-and verified that outlook has the scripts by pulling down the scroll menu-they are there but Im not sure how to activate them or use them. I use shift-ctrl-c to use the pop up menu for dialing but what Im trying to do is log those calls like I used to do in ical. I just switched back to outlook(lost search functions but not your issue).

Man this software just keeps getting better and better!
u352
 
Posts: 2
Joined: Thu Apr 17, 2014 11:58 am

Re: Activating Scripts in outlook

Postby psichel_adm » Sun Apr 27, 2014 9:23 pm

For activating scripts, you'll want to review the information here:

http://www.sustworks.com/pa_guide/scripting.html

When a call arrives with caller ID (call_from), you'll want to invoke the corresponding script.

For dialing, you could use the will_dial event.

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm

Re: Activating Scripts in outlook

Postby kaya67 » Thu Oct 30, 2014 2:34 am

Any updates on this? When I use my attached usb microphone, the input level gets switched down the moment the call is connected; I can see that if I e.g. tap on my microphone and have the audio control panel open - moving the sound level slider around there does not help; it is as if the microphone was just muted. I switched off echo (both in plist as well as using 1.4.15.1) and also tried all kinds of other versions of phone amego from your download. I also reset the bluetooth stack and removed all superfluous devices.
You can try out our 650-987 free brain dumps latest resource ASQ exam and high quality wikipedia Also get free demos of Stanford University certification and 220-702 practice questions Miami International University of Art & Design
kaya67
 
Posts: 1
Joined: Thu Oct 30, 2014 2:29 am

Re: Activating Scripts in outlook

Postby psichel_adm » Thu Oct 30, 2014 10:24 pm

What version of OS X?

For 10.9 or later, Apple controls the audio stack from inside the Bluetooth Handsfree Device API. The only thing PA can adjust is the audio level in the System Audio Preferences (the same as you can). If you say more about the exact context in which the behavior isn't what you're expecting, I can better assess whether there's something Phone Amego can do to help. For 10.8, PA can attempt some echo suppression by turning down the Mic gain while there's incoming audio.

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm


Return to Phone Amego

Who is online

Users browsing this forum: No registered users and 2 guests