Page 1 of 1

Activating Scripts in outlook

PostPosted: Thu Apr 17, 2014 1:12 pm
by u352
Ive downloaded the some scripts from the extras section and have placed them library/application support folder.What do i do from here?

T

Re: Activating Scripts in outlook

PostPosted: Thu Apr 17, 2014 9:23 pm
by psichel_adm
See http://www.sustworks.com/pa_guide/scripting.html

Can you say more about what you want to do and which step isn't clear?

For dialing, you can select a phone number in Outlook and press Control-Shift-2 or use PopClip to click directly.

For inbound Caller ID, you want to set a script for the "call_from()", "call_info()", or "did_dial()" event.

Were you able to find the MS Outlook scripts in the Phone Amego Extra's folder?

Kind Regards,

- Peter

Re: Activating Scripts in outlook

PostPosted: Fri Apr 18, 2014 8:16 am
by u352
Ok so let me try again.

Ive downloaded the Phone Amegos Extras and dropped them in the OUTLOOKS Script folder-and verified that outlook has the scripts by pulling down the scroll menu-they are there but Im not sure how to activate them or use them. I use shift-ctrl-c to use the pop up menu for dialing but what Im trying to do is log those calls like I used to do in ical. I just switched back to outlook(lost search functions but not your issue).

Man this software just keeps getting better and better!

Re: Activating Scripts in outlook

PostPosted: Sun Apr 27, 2014 9:23 pm
by psichel_adm
For activating scripts, you'll want to review the information here:

http://www.sustworks.com/pa_guide/scripting.html

When a call arrives with caller ID (call_from), you'll want to invoke the corresponding script.

For dialing, you could use the will_dial event.

Kind Regards,

- Peter

Re: Activating Scripts in outlook

PostPosted: Thu Oct 30, 2014 2:34 am
by kaya67
Any updates on this? When I use my attached usb microphone, the input level gets switched down the moment the call is connected; I can see that if I e.g. tap on my microphone and have the audio control panel open - moving the sound level slider around there does not help; it is as if the microphone was just muted. I switched off echo (both in plist as well as using 1.4.15.1) and also tried all kinds of other versions of phone amego from your download. I also reset the bluetooth stack and removed all superfluous devices.

Re: Activating Scripts in outlook

PostPosted: Thu Oct 30, 2014 10:24 pm
by psichel_adm
What version of OS X?

For 10.9 or later, Apple controls the audio stack from inside the Bluetooth Handsfree Device API. The only thing PA can adjust is the audio level in the System Audio Preferences (the same as you can). If you say more about the exact context in which the behavior isn't what you're expecting, I can better assess whether there's something Phone Amego can do to help. For 10.8, PA can attempt some echo suppression by turning down the Mic gain while there's incoming audio.

Kind Regards,

- Peter