Codepage issues.

Forum to share information about Phone Amego and get help to answer your questions

Codepage issues.

Postby Bad Santa » Tue May 27, 2014 9:12 am

Hi Peter,
I see the following problem when I dial from iPhone: http://take.ms/CbG3q

When I dial from mac, everything looks fine. The name of the person in in Russian, cyrillic.

Thanks for any suggestions,
Egor.
Bad Santa
 
Posts: 13
Joined: Wed May 21, 2014 7:09 am

Re: Codepage issues.

Postby psichel_adm » Tue May 27, 2014 9:34 pm

Phone Amego requests the iPhone use UTF-8 and then requests the character set actually used to employ the correct encoding.

Phone Amego has a Debug Log you can enable under the More tab. It should allow us to see what character set is being requested and reported by both ends of the connection.

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm

Re: Codepage issues.

Postby Bad Santa » Thu May 29, 2014 8:33 am

Every issue has a reason. I just point on this, you do the rest, Peter.
Bad Santa
 
Posts: 13
Joined: Wed May 21, 2014 7:09 am

Re: Codepage issues.

Postby psichel_adm » Sat Jun 21, 2014 3:19 pm

In 10.9 and later, Apple's new API (IOBluetoothHandFreeDevice) handles character set coding. If you can send me an example that shows the failure, I'll forward this to my contact at Apple.

The description I gave above is for 10.8 and earlier.

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm


Return to Phone Amego

Who is online

Users browsing this forum: No registered users and 1 guest

cron