Page 2 of 2

Re: Troubleshooting

PostPosted: Sat Oct 27, 2012 8:31 pm
by dchadwick
Well, I'm running two machines with 10.8.2, a Mini and an Air — the Mini has zero problems with Keyclick, but it frequently stops working on the Air after sleep. I can't think of anything I have running on the Air that I don't have on the Mini.

I remember a while back there was an issue (I think) related to portable Macs shutting off their sound systems in such a way that interfered with Keyclick. It was fixed at that time, but could this be something similar?

Happy to provide any logs or diagnostic info needed.

Re: Troubleshooting

PostPosted: Wed Oct 31, 2012 11:14 am
by psichel_adm
Is it consistent, or just sometimes after sleep?
Can check in the Sound preferences to see if other alert sounds are still working?

On my MacBook Pro (late 2011, 10.8.2), Alert sounds sometimes stop working (since upgrading to Mountain Lion), but it's not consistent. It might happen after a few days.

- Peter

Re: Troubleshooting

PostPosted: Sun Nov 25, 2012 7:33 pm
by dchadwick
Well, it turns out I'm now having system alert sounds in general (including Keyclick) go mute in general after sleep.

Looks like this is a known problem:

Sound Effects Not working Correctly in Mail 6.0 or Notification Center...
https://discussions.apple.com/message/19141725#19141725

Re: Troubleshooting

PostPosted: Wed Dec 05, 2012 9:17 pm
by dchadwick
I've been just restarting the "coreaudio" process, which appears to solve the issue for many people without restarting. As a bonus, I'm using Alfred to launch very quickly the command referenced here.
http://naudo.de/post/20014792593/rebooting-core-audio

Works like a charm, and quicker than a trip to Activity Monitor — and definitely quicker than restarting just to get my sounds back!

Re: Troubleshooting

PostPosted: Wed Dec 19, 2012 4:34 am
by panomedia
I was directed to review this thread by Peter since I was having similar issues to other here on this board. Most of the problems I see are being diagnosed as being caused by Core Audio issues and/or issues when waking from sleep. I have been using Keyclick for years now and rarely had regular issues until recently after an upgrade to Mountain Lion. As upgrades through Lion progressed over the years I did notice some flakiness, but not as regularly as now.

I have a MacPro and a MBP both running 10.8.2 and using Keyclick on both. On both systems, all screensaver activation, power management savings plans and hard disk sleep are set to NEVER. All drives spin all the time on the MacPro. The MBP has an SSD and a second 7200 drive which spins always.

Most of this week has been okay with Keyclick not failing at any time on either box. Yesterday was an exception. Both machines had issues where I simply replaced the prefpane, turned it off and then back on again and Keyclick was fine. I used to reboot, just like others here have been doing, but found a prefpane replacement worked just as well.

The issue also does not seem dependent upon what you are doing. I have left a machine untouched for an hour only to find when I return Keyclick does not work. I have also been right in the middle of typing into a web page input box and blam, no Keyclick.

I am not even remotely close to having any programming knowledge, I am simply trying to provide the gurus that can do something, some material to work with.

Hopefully this will be resolved some time in the near future - I have gotten so used to having a positive typing audio response I almost cannot function without it. Kudos to Sustworks for creating such a valuable tool.

Re: Troubleshooting

PostPosted: Fri Dec 21, 2012 12:30 pm
by psichel_adm
Thanks for writing. Part of the issue here is that no other tool loads a sound and plays it thousands of times over days or weeks. This pattern has a way of uncovering subtle bugs in Core Audio that Apple's normal test regime fails to identify.

In this case however, one of the bugs is widely reported outside the context of Keyclick so I expect this to be addressed more quickly.

- Peter

Re: Troubleshooting

PostPosted: Tue Feb 16, 2016 1:47 am
by dchadwick
Anybody else having trouble with Keyclick dying under El Capitan? For me, it goes away at times after sleep, but comes back after a restart.

Re: Troubleshooting

PostPosted: Sun Feb 21, 2016 5:35 am
by psichel_adm
Try changing the Keyclick volume (by keyboard shortcut). That will reload the system sound (which OS X may have lost).

Re: Troubleshooting

PostPosted: Sun Feb 21, 2016 10:33 pm
by dchadwick
Tried that -- it just isn't responding.

Re: Troubleshooting

PostPosted: Sat Apr 02, 2016 5:01 pm
by psichel_adm
Have you tried restarting?

Another possibility is the Keyclick can no longer see its registration data stored at /Library/Application Support/Keyclick_key. Check the permissions on this file to be sure the logged in user can read it.

Kind Regards,

- Peter