ü,ä,ö won't show properly in daylite

Forum to share information about Phone Amego and get help to answer your questions

ü,ä,ö won't show properly in daylite

Postby squandokan » Tue Dec 03, 2013 11:21 am

hey guys...

since i'm from germany, i have some customers with ä ö ü in their names (ae, ue, oe) but i only get weird characters in the hud and in the note that is created in daylite... any idea?

thanks!
squandokan
 
Posts: 3
Joined: Thu Nov 28, 2013 11:10 am

Re: ü,ä,ö won't show properly in daylite

Postby psichel_adm » Tue Dec 03, 2013 6:03 pm

This is a bug in OS X Mavericks (10.9).

You can work around this by removing your iPhone as a telephone device in Phone Amego, and then adding it back as device type “Alternate HFP”. This will revert back to the previous Bluetooth API code but no longer has any control over call audio.

I have reported the problem to Apple and expect it to be fixed in the next update.

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm

Re: ü,ä,ö won't show properly in daylite

Postby squandokan » Wed Dec 04, 2013 9:30 am

well actually it's an aastra 6755i .... same issue?
squandokan
 
Posts: 3
Joined: Thu Nov 28, 2013 11:10 am

Re: ü,ä,ö won't show properly in daylite

Postby psichel_adm » Thu Dec 05, 2013 5:39 pm

Not exactly. For Aastra and other IP phones, the caller ID information is typically included as part of the notification URL. I assumed these URLs would be UTF8 encoded but its possible Aastra did something else. I'll need to investigate what character encoding is used in order to translate it properly.

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm

Re: ü,ä,ö won't show properly in daylite

Postby psichel_adm » Tue Dec 10, 2013 5:37 pm

My look at the manual shows no indication of what the character encoding actually is.

ftp://downloads.aastra.com/Downloads/Ad ... 8_2013.pdf

Can you Email me the text output from the Debug Log window after Phone Amego fails to display the Caller ID as expected?
Or is it only Daylite that is mis-interpreting the character encoding?

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm


Return to Phone Amego

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron