iPhone 5s + Mavericks + older macbook air = No Audio

Forum to share information about Phone Amego and get help to answer your questions

iPhone 5s + Mavericks + older macbook air = No Audio

Postby steverobinson » Thu Jun 26, 2014 4:25 pm

I have been unable to get audio to work through my computer at all since installing phone amego. I am able to run phone amego, connect to my iPhone, place calls, control the phone through the HUD, but when I send the audio to the computer, with "Use Speakerphone" checked or unchecked, i hear a faint click, but get no sound. If I tell the HUD to transfer audio to phone, I get perfect audio on the phone. If I transfer audio back to computer, nothing.

Concerned that it was an issue with using an older macbook air (late 2010), I installed a third-party USB bluetooth dongle, which has increased my range, but did not resolve this problem.

Everything appears normal in the logs from what I can tell, but I don't know if I'm looking at the right logs.

Any thoughts? What more information do you need from me?
steverobinson
 
Posts: 1
Joined: Thu Jun 26, 2014 4:15 pm

Re: iPhone 5s + Mavericks + older macbook air = No Audio

Postby psichel_adm » Fri Jul 04, 2014 4:35 pm

What version of Mac OS X?

The Buetooth audio driver in previous systems does not work on some Macs which you can verify in the system console.

In Mavericks, Apple has taken over the Bluetooth audio stack so it should work for most users but some will notice echo cancellation artifacts.

Another possibility is that some other software on your computer has captured the Bluetooth audio port. Do you have other audio software like FaceTime or Skype configured?

It shouldn't be this difficult, but Phone Amego is at the mercy of Bluetooth audio not unlike how Safari is at the mercy of your cable modem. It has to work and Phone Amego alone has very little control.

Kind Regards,

- Peter
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm

Re: iPhone 5s + Mavericks + older macbook air = No Audio

Postby Roddy » Wed Jan 28, 2015 3:42 am

So the "Open Call Window" shortcut is working, but the Place Call menu item is missing. This sounds like some weird bug in populating the menu. Can you try removing the Phone Amego preferences file at ~/Library/Preferences/com.sustworks.PhoneAmego.plist . Then re-launch Phone Amego. I'm guessing this will restore the lost menu item.
________
http://www.certkiller.org
Last edited by Roddy on Sat Jan 23, 2016 6:42 am, edited 2 times in total.
Roddy
 
Posts: 1
Joined: Wed Jan 28, 2015 3:41 am

Re: iPhone 5s + Mavericks + older macbook air = No Audio

Postby psichel_adm » Wed Feb 04, 2015 9:15 pm

Make sure you have selected "Dial" instead of "SMS" in the Call window.

This should probably be cleaned up since it confuses some users.
psichel_adm
Site Admin
 
Posts: 463
Joined: Mon May 03, 2010 7:49 pm


Return to Phone Amego

Who is online

Users browsing this forum: No registered users and 3 guests

cron